import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D0[\\D\\$]";
final String string = "(((7+5)*75)+(3*0))+2 = 902\n"
+ "((7+5)*75)+(3*0))+2 = 902\n"
+ "(7+5)*75+(3*0)+2 = 902\n"
+ "(7+5)*75+3*0+2 = 292\n"
+ "(75-9)*(8-1)-10+0\n"
+ "0+(75-9)*(8-1)-10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}