import Foundation
let pattern = #"\D0[\D\$]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292
(75-9)*(8-1)-10+0
0+(75-9)*(8-1)-10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)