$re = '/\D0[\D\$]/m';
$str = '(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292
(75-9)*(8-1)-10+0
0+(75-9)*(8-1)-10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);