#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+\s*=\s*(?:"[^"\n]*(?:"|$)|\S+(?=,|$))"
Local $sString = "Include="All Violations", CheckType=MaxTrans" & @CRLF & _
"MetricName = PlacedInstances, PlacedOnly = 1" & @CRLF & _
"CheckType=Hold, Include="reg2reg,in2reg,in2out,reg2out"" & @CRLF & _
"CheckType=Setup, Include="reg2reg,in2reg,in2out,reg2out" & @CRLF & _
"" & @CRLF & _
"MetricName = PlacedInstances, PlacedOnly = 1, PlacedOnly = 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")