import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s*=\\s*(?:\"[^\"\\n]*(?:\"|$)|\\S+(?=,|$))";
final String string = "Include=\"All Violations\", CheckType=MaxTrans\n"
+ "MetricName = PlacedInstances, PlacedOnly = 1\n"
+ "CheckType=Hold, Include=\"reg2reg,in2reg,in2out,reg2out\"\n"
+ "CheckType=Setup, Include=\"reg2reg,in2reg,in2out,reg2out\n\n"
+ "MetricName = PlacedInstances, PlacedOnly = 1, PlacedOnly = 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}