re = /\w+\s*=\s*(?:"[^"\n]*(?:"|$)|\S+(?=,|$))/m
str = 'Include="All Violations", CheckType=MaxTrans
MetricName = PlacedInstances, PlacedOnly = 1
CheckType=Hold, Include="reg2reg,in2reg,in2out,reg2out"
CheckType=Setup, Include="reg2reg,in2reg,in2out,reg2out
MetricName = PlacedInstances, PlacedOnly = 1, PlacedOnly = 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end