import re
regex = re.compile(r"\w+\s*=\s*(?:\"[^\"\n]*(?:\"|$)|\S+(?=,|$))", flags=re.MULTILINE)
test_str = ("Include=\"All Violations\", CheckType=MaxTrans\n"
"MetricName = PlacedInstances, PlacedOnly = 1\n"
"CheckType=Hold, Include=\"reg2reg,in2reg,in2out,reg2out\"\n"
"CheckType=Setup, Include=\"reg2reg,in2reg,in2out,reg2out\n\n"
"MetricName = PlacedInstances, PlacedOnly = 1, PlacedOnly = 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")