using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s*=\s*(?:""[^""\n]*(?:""|$)|\S+(?=,|$))";
string input = @"Include=""All Violations"", CheckType=MaxTrans
MetricName = PlacedInstances, PlacedOnly = 1
CheckType=Hold, Include=""reg2reg,in2reg,in2out,reg2out""
CheckType=Setup, Include=""reg2reg,in2reg,in2out,reg2out
MetricName = PlacedInstances, PlacedOnly = 1, PlacedOnly = 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}