using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p class=""h2"">(.+)<\/p>";
string substitution = @"<h4 class=""font-title"">$1</h4>";
string input = @"<p class=""h2"">Наличие и условия предоставления стипендий</p>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}