re = /<p class="h2">(.+)<\/p>/i
str = '<p class="h2">Наличие и условия предоставления стипендий</p>'
subst = '<h4 class="font-title">$1</h4>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result