const regex = /<p class="h2">(.+)<\/p>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p class="h2">(.+)<\\\/p>', 'i')
const str = `<p class="h2">Наличие и условия предоставления стипендий</p>`;
const subst = `<h4 class="font-title">$1</h4>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);