$re = '/<p class="h2">(.+)<\/p>/i';
$str = '<p class="h2">Наличие и условия предоставления стипендий</p>';
$subst = "<h4 class=\"font-title\">$1</h4>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;