re = /value="([^"]+)"/m
str = '<input name="formToken" type="hidden" value="19225544fb878c9a8c77dafdfe616454a13e3c96" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end