// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)value="([^"]+)""#).unwrap();
let string = "<input name=\"formToken\" type=\"hidden\" value=\"19225544fb878c9a8c77dafdfe616454a13e3c96\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}