#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\n\r].*Name : \s*([^\n\r].+?(?= \/))"
Local $sString = "1. Request Number : REQ0128566 / Ref:MSG9040321" & @CRLF & _
"New Hire Name : Paul Truong / Reporting To : Michael Eden" & @CRLF & _
"Department : Office Services / Company: Warner Music Nashville LLC" & @CRLF & _
"Start Date : 2020-07-28 / Worker's Status : Outsourced" & @CRLF & _
"Email Retention Selected: WAS 2 Years – CHANGE to 5 Years (Office Serv Consult)" & @CRLF & _
"Job Title: Security"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")