use strict;
my $str = '1. Request Number : REQ0128566 / Ref:MSG9040321
New Hire Name : Paul Truong / Reporting To : Michael Eden
Department : Office Services / Company: Warner Music Nashville LLC
Start Date : 2020-07-28 / Worker\'s Status : Outsourced
Email Retention Selected: WAS 2 Years – CHANGE to 5 Years (Office Serv Consult)
Job Title: Security';
my $regex = qr/[\n\r].*Name : \s*([^\n\r].+?(?= \/))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}