import Foundation
let pattern = #"[\n\r].*Name : \s*([^\n\r].+?(?= \/))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. Request Number : REQ0128566 / Ref:MSG9040321
New Hire Name : Paul Truong / Reporting To : Michael Eden
Department : Office Services / Company: Warner Music Nashville LLC
Start Date : 2020-07-28 / Worker's Status : Outsourced
Email Retention Selected: WAS 2 Years – CHANGE to 5 Years (Office Serv Consult)
Job Title: Security
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)