import re
regex = re.compile(r"[\n\r].*Name : \s*([^\n\r].+?(?= \/))", flags=re.MULTILINE)
test_str = ("1. Request Number : REQ0128566 / Ref:MSG9040321\n"
"New Hire Name : Paul Truong / Reporting To : Michael Eden\n"
"Department : Office Services / Company: Warner Music Nashville LLC\n"
"Start Date : 2020-07-28 / Worker's Status : Outsourced\n"
"Email Retention Selected: WAS 2 Years – CHANGE to 5 Years (Office Serv Consult)\n"
"Job Title: Security")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")