#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^{%\s+include\s+['\"]([^{]+)['\"].*?%}$"
Local $sString = "{% include 'Components/_datetime.html.twig' with {'event_count': event_count, 'hide_time': false} %}" & @CRLF & _
"{% include 'sidebar.html' ignore missing %}" & @CRLF & _
"{% include 'sidebar.html' ignore missing with {'foo': 'bar'} %}" & @CRLF & _
"{% include 'sidebar.html' ignore missing only %}" & @CRLF & _
"{% include "Components/_datetime.html.twig" with {'event_count': event_count, 'hide_time': false} %}" & @CRLF & _
"{% include "sidebar.html" ignore missing %}" & @CRLF & _
"{% include "sidebar.html" ignore missing with {'foo': 'bar'} %}" & @CRLF & _
"{% include "sidebar.html" ignore missing only %}" & @CRLF & _
"{% include ['page_detailed.html', 'page.html'] %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")