re = /^{%\s+include\s+['\"]([^{]+)['\"].*?%}$/m
str = '{% include \'Components/_datetime.html.twig\' with {\'event_count\': event_count, \'hide_time\': false} %}
{% include \'sidebar.html\' ignore missing %}
{% include \'sidebar.html\' ignore missing with {\'foo\': \'bar\'} %}
{% include \'sidebar.html\' ignore missing only %}
{% include "Components/_datetime.html.twig" with {\'event_count\': event_count, \'hide_time\': false} %}
{% include "sidebar.html" ignore missing %}
{% include "sidebar.html" ignore missing with {\'foo\': \'bar\'} %}
{% include "sidebar.html" ignore missing only %}
{% include [\'page_detailed.html\', \'page.html\'] %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end