package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{%\s+include\s+['\"]([^{]+)['\"].*?%}$`)
var str = `{% include 'Components/_datetime.html.twig' with {'event_count': event_count, 'hide_time': false} %}
{% include 'sidebar.html' ignore missing %}
{% include 'sidebar.html' ignore missing with {'foo': 'bar'} %}
{% include 'sidebar.html' ignore missing only %}
{% include "Components/_datetime.html.twig" with {'event_count': event_count, 'hide_time': false} %}
{% include "sidebar.html" ignore missing %}
{% include "sidebar.html" ignore missing with {'foo': 'bar'} %}
{% include "sidebar.html" ignore missing only %}
{% include ['page_detailed.html', 'page.html'] %}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}