using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{%\s+include\s+['\""]([^{]+)['\""].*?%}$";
string input = @"{% include 'Components/_datetime.html.twig' with {'event_count': event_count, 'hide_time': false} %}
{% include 'sidebar.html' ignore missing %}
{% include 'sidebar.html' ignore missing with {'foo': 'bar'} %}
{% include 'sidebar.html' ignore missing only %}
{% include ""Components/_datetime.html.twig"" with {'event_count': event_count, 'hide_time': false} %}
{% include ""sidebar.html"" ignore missing %}
{% include ""sidebar.html"" ignore missing with {'foo': 'bar'} %}
{% include ""sidebar.html"" ignore missing only %}
{% include ['page_detailed.html', 'page.html'] %}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}