use strict;
my $str = '{% include \'Components/_datetime.html.twig\' with {\'event_count\': event_count, \'hide_time\': false} %}
{% include \'sidebar.html\' ignore missing %}
{% include \'sidebar.html\' ignore missing with {\'foo\': \'bar\'} %}
{% include \'sidebar.html\' ignore missing only %}
{% include "Components/_datetime.html.twig" with {\'event_count\': event_count, \'hide_time\': false} %}
{% include "sidebar.html" ignore missing %}
{% include "sidebar.html" ignore missing with {\'foo\': \'bar\'} %}
{% include "sidebar.html" ignore missing only %}
{% include [\'page_detailed.html\', \'page.html\'] %}';
my $regex = qr/^{%\s+include\s+['\"]([^{]+)['\"].*?%}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}