#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_en(\.|$)(?!.*_[a-z]{2}(\.|$))"
Local $sString = "title_en" & @CRLF & _
"components_en.video.title" & @CRLF & _
"components_en.video.title_en" & @CRLF & _
"components_en.video.the_end" & @CRLF & _
"components_es.video.title_en" & @CRLF & _
"title_es" & @CRLF & _
"components_es.video.title" & @CRLF & _
"components_en.video.title_es" & @CRLF & _
"components_es.video.the_end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")