use strict;
my $str = 'title_en
components_en.video.title
components_en.video.title_en
components_en.video.the_end
components_es.video.title_en
title_es
components_es.video.title
components_en.video.title_es
components_es.video.the_end';
my $regex = qr/_en(\.|$)(?!.*_[a-z]{2}(\.|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}