import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_en(\\.|$)(?!.*_[a-z]{2}(\\.|$))";
final String string = "title_en\n"
+ "components_en.video.title\n"
+ "components_en.video.title_en\n"
+ "components_en.video.the_end\n"
+ "components_es.video.title_en\n"
+ "title_es\n"
+ "components_es.video.title\n"
+ "components_en.video.title_es\n"
+ "components_es.video.the_end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}