$re = '/_en(\.|$)(?!.*_[a-z]{2}(\.|$))/m';
$str = 'title_en
components_en.video.title
components_en.video.title_en
components_en.video.the_end
components_es.video.title_en
title_es
components_es.video.title
components_en.video.title_es
components_es.video.the_end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);