import re
regex = re.compile(r"_en(\.|$)(?!.*_[a-z]{2}(\.|$))", flags=re.MULTILINE)
test_str = ("title_en\n"
"components_en.video.title\n"
"components_en.video.title_en\n"
"components_en.video.the_end\n"
"components_es.video.title_en\n"
"title_es\n"
"components_es.video.title\n"
"components_en.video.title_es\n"
"components_es.video.the_end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")