# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("position": \[\d+(?:\.?\d*), \d+(?:\.?\d*))(])/\1, 0\2/gm;t' <<< "\"position\": [0, 0]
\"position\": [0.1, 0]
\"position\": [0, 0.1]
\"position\": [0.1, 0.1]"