use strict;
my $str = '"position": [0, 0]
"position": [0.1, 0]
"position": [0, 0.1]
"position": [0.1, 0.1]';
my $regex = qr/("position": \[\d+(?:\.?\d*), \d+(?:\.?\d*))(])/mp;
my $subst = '\\1, 0\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";