import Foundation
let pattern = #"("position": \[\d+(?:\.?\d*), \d+(?:\.?\d*))(])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"position": [0, 0]
"position": [0.1, 0]
"position": [0, 0.1]
"position": [0.1, 0.1]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1, 0\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)