using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""position"": \[\d+(?:\.?\d*), \d+(?:\.?\d*))(])";
string substitution = @"\1, 0\2";
string input = @"""position"": [0, 0]
""position"": [0.1, 0]
""position"": [0, 0.1]
""position"": [0.1, 0.1]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}