package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("position": \[\d+(?:\.?\d*), \d+(?:\.?\d*))(])`)
var str = `"position": [0, 0]
"position": [0.1, 0]
"position": [0, 0.1]
"position": [0.1, 0.1]`
var substitution = "\1, 0\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}