#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*?(WHERE.*?)(GROUP BY|;|\n)"
Local $sString = "s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId" & @CRLF & _
" WHERE clinic_drug.amount = 0 " & @CRLF & _
" GROUP BY clinics.name;'''" & @CRLF & _
"" & @CRLF & _
"s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId" & @CRLF & _
" WHERE clinic_drug.amount = 2 " & @CRLF & _
" GROUP BY clinics.name;'''" & @CRLF & _
"" & @CRLF & _
"s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId" & @CRLF & _
" WHERE clinic_drug.amount = 3;"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)