$re = '/.*?(WHERE.*?)(GROUP BY|;|\n)/s';
$str = 's = \'\'\'FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 0
GROUP BY clinics.name;\'\'\'
s = \'\'\'FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 2
GROUP BY clinics.name;\'\'\'
s = \'\'\'FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 3;';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;