using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(WHERE.*?)(GROUP BY|;|\n)";
string substitution = @"$1\n";
string input = @"s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 0
GROUP BY clinics.name;'''
s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 2
GROUP BY clinics.name;'''
s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 3;";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}