# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(WHERE.*?)(GROUP BY|;|\n)"
test_str = ("s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId\n"
" WHERE clinic_drug.amount = 0 \n"
" GROUP BY clinics.name;'''\n\n"
"s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId\n"
" WHERE clinic_drug.amount = 2 \n"
" GROUP BY clinics.name;'''\n\n"
"s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId\n"
" WHERE clinic_drug.amount = 3;")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.