// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s).*?(WHERE.*?)(GROUP BY|;|\n)").unwrap();
let string = "s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 0
GROUP BY clinics.name;'''
s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 2
GROUP BY clinics.name;'''
s = '''FROM clinics INNER JOIN clinic_drug on clinics.clinicId = clinic_drug.clinicId
WHERE clinic_drug.amount = 3;";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}