using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?=('|"").*('|""))('|"")|('|"")(?<=('|"").*('|"")).*";
string substitution = @"";
string input = @"print('asdf')
console.log(""asdfasdfasdf"")
clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)
functions = inspect.getmembers(sys.modules['__main__'], inspect.isfunction)
clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}