const regex = /.*(?=('|").*('|"))('|")|('|")(?<=('|").*('|")).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?=(\'|").*(\'|"))(\'|")|(\'|")(?<=(\'|").*(\'|")).*', 'g')
const str = `print('asdf')
console.log("asdfasdfasdf")
clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)
functions = inspect.getmembers(sys.modules['__main__'], inspect.isfunction)
clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);