import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(?=('|\").*('|\"))('|\")|('|\")(?<=('|\").*('|\")).*";
final String string = "print('asdf')\n"
+ "console.log(\"asdfasdfasdf\")\n"
+ "clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)\n"
+ "functions = inspect.getmembers(sys.modules['__main__'], inspect.isfunction)\n"
+ "clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}