import re
regex = re.compile(r".*(?=('|\").*('|\"))('|\")|('|\")(?<=('|\").*('|\")).*")
test_str = ("print('asdf')\n"
"console.log(\"asdfasdfasdf\")\n"
"clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)\n"
"functions = inspect.getmembers(sys.modules['__main__'], inspect.isfunction)\n"
"clsmembers = inspect.getmembers(sys.modules['__main__'], inspect.isclass)\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)