#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=src=").+?(?=")"
Local $sString = "Ut quo totam aperiam possimus recusandae" & @CRLF & _
"<img src="mylink.jpg"/>" & @CRLF & _
"Bo nostrum vero distinctio eligendi." & @CRLF & _
"<img src="mylinktmpfileandsomeotherstuff.jpg"/>" & @CRLF & _
"<img src="myotherlink.jpg"/>" & @CRLF & _
"Lorem ipsum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")