$re = '/(?<=src=").+?(?=")/';
$str = 'Ut quo totam aperiam possimus recusandae
<img src="mylink.jpg"/>
Bo nostrum vero distinctio eligendi.
<img src="mylinktmpfileandsomeotherstuff.jpg"/>
<img src="myotherlink.jpg"/>
Lorem ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);