import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src=\").+?(?=\")";
final String string = "Ut quo totam aperiam possimus recusandae\n"
+ "<img src=\"mylink.jpg\"/>\n"
+ "Bo nostrum vero distinctio eligendi.\n"
+ "<img src=\"mylinktmpfileandsomeotherstuff.jpg\"/>\n"
+ "<img src=\"myotherlink.jpg\"/>\n"
+ "Lorem ipsum";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}