re = /(?<=src=").+?(?=")/
str = 'Ut quo totam aperiam possimus recusandae
<img src="mylink.jpg"/>
Bo nostrum vero distinctio eligendi.
<img src="mylinktmpfileandsomeotherstuff.jpg"/>
<img src="myotherlink.jpg"/>
Lorem ipsum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end