using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=src="").+?(?="")";
string input = @"Ut quo totam aperiam possimus recusandae
<img src=""mylink.jpg""/>
Bo nostrum vero distinctio eligendi.
<img src=""mylinktmpfileandsomeotherstuff.jpg""/>
<img src=""myotherlink.jpg""/>
Lorem ipsum";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}