package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ip=(.*)$`)
var str = `fl=4f422
h=www.cloudflare.com
ip=54.193.27.106
ts=1575967108.245`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}