const regex = /^ip=(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ip=(.*)$', 'gm')
const str = `fl=4f422
h=www.cloudflare.com
ip=54.193.27.106
ts=1575967108.245`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}