re = /^ip=(.*)$/m
str = 'fl=4f422
h=www.cloudflare.com
ip=54.193.27.106
ts=1575967108.245'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end